Exklusiv bei Conrad
Dm-Toys

Link/Rank-Liste:
Stimme für 1zu160 bei Spurweite-N.de


powered by
World4You.com


1zu160 - Forum  |  Sie sind: Gast  |  Login  |  Neu Registrieren


Anzeige:
DM TOYS

Wahl zur Neukonstruktion des Jahres

Thema: PWM-Probleme bei FL 7375
Story - 11.01.21 21:35

Hallo alle PWM-Spezialisten,
nach 5 Jahren Pause habe ich die Moba mal entstaubt und begonnen, alle Motoren zu warten, da viele verharzt waren. Vor Jahren hatte ich nach Analogbetrieb auf PWM umgestellt und schon damals fiel auf, dass sich alte Schlepptenderloks mit  3pol. Motor sehr schön (langsam-) fahren und regeln lassen. Die Ellok FL 7375 der BR103 (allerdings auch BJ 1998 und 3-polig) jedoch fährt hier wesentlich langsamer als mit Gleichstrom und lässt sich auch schlecht regeln. Liegt das evtl. an dem Kondensator (64 4202) und / oder der Drossel (64 4101)?? Leider habe ich vergessen, wie ich die PWM-Frequenz ausgelegt habe, mit Sicherheit aber zwischen 12 und 16kHz. Könnte es der Kondensator sein, der hier (fast) einen Kurzschluß verursacht. Sollte ich beides mal wahlweise von der Platine ablöten oder geht dann der Motor hops mit Bürstenfeuer? Was meint Ihr?
Gruß Uli


Die Frage ist, was für ein PWM das ist. Wird nur aktiv ein- oder auch ausgeschaltet. Bei letzterer Betriebsart würde also die Gegen-EMK wieder kurzgeschlossen, was ein extrem gutes Regelverhalten ergibt, aber für die Mechanik extrem gewalttätig ist.

Wenn da ein Kondensator drin ist und Du nur "aktiv ein" als PWM nutzt, dann macht der Kondensator ja eigentlich nur DC aus dem PWM. Da sollte mal gar nichts passieren. Bei "aktiv aus" ist das in der Tat aber der volle Kurzschluß. Dann muß der raus, sonst heizt der nur.

Die Drossel wird sich bei "aktiv aus" als Widerstand bemerkbar machen und könnte dann das langsame Fahren erklären. Bei nur "aktiv ein" ist die egal, ist am Motor eh beinahe DC bei der Frequenz.

Bürstenfeuer bei > 15kHz und nur "aktiv ein" glaub ich nicht, bei auch "aktiv aus" kann je nach Motorbauart aber die Post abgehen. So habe ich seinerzeit eine Köf geschrottet. Sie fuhr zwar langsamer als ich gucken konnte, aber nach ca. 15 Sekunden war da einiges abgefackelt

Gruß
Klaus

Hallo Klaus,
Vielen dank für Deine Hinweise! Zur Frage, was es

Die von Story zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login


Äh... wie meinen Da scheint aber was schief gelaufen zu sein...

Gruß
Klaus

Hallo Klaus,
ja da lag die SENDEN-Taste wohl zu nahe
Die PWM ist klassisch mit gesteuertem EIN und AUS, s. Bild oben im abgehackter Antwort.
Der Kondensator (parallel zu den Bürsten) hat mit 1nF bei 14kHz eine Reaktanz von 11,3kOhm und da verschwindet sicher keine Leistung oder gar Kurzschluß. Evtl. die Drossel?
Grau ist alle Theorie, ich probiers mal durch wechselweises Auslöten aus und melde mich, was da rauskommt.
Das mit der Köf kann ich mindestens!
Gruß Uli

Zitat

Die PWM ist klassisch mit gesteuertem EIN und AU



Ich sag mal so: Dein Diagramm sagt nicht aus, ob die Nullphase auch aktiv nach null schaltet oder ob sie "nur" keine Spannung mehr liefert. Nicht das wir da aneinander vorbei schreiben

Zitat

Der Kondensator (parallel zu den Bürsten) hat mit 1nF bei 14kHz eine Reaktanz von 11,3kOhm



Ja, da hast Du aber die Rechnung ohne die Wellenform gemacht Bei Sinus hast Du recht, aber die "Frequenz" die der Kondensator sieht, ist die der Anstiegsgeschwindigkeit und nicht die der Wiederholung/Taktung.

Zitat

Grau ist alle Theorie, ich probiers mal durch wechselweises Auslöten



<Klugscheißmodus>
Bei der Drossel würde ich nicht auslöten, sondern Überbrücken, sonst geht nicht mehr viel
</Klugscheißmodus>

Gruß
Klaus

Hallo Klaus,
jetzt mach ich mal, was Du sagst.
Die 112 ist schnell gewählt!

Zitat - Antwort-Nr.: | Name:


Drossel ist raus und stattdessen habe ich eine Brücke eingelötet.

Der Kondensator ist auch raus.

Zu Anfangs lief sie gut und nach geraumer Zeit ruckte sie und blieb stehen.
Das war nicht überzeugend. Also schnell die Spannung weg bevor sie noch abraucht.

Vl. kehre Ich zum guten alten Gleichstrom zurück, regele an Steigungen halt nach und nehme schlechteres Anfahr- und Bremsverhalten in Kauf .

Gruß Uli

Hallo Klaus,

Vielen Dank nochmal für die Ratschläge! 👍
Ich werde mal die PWM anschauen, vl. gibt es noch Hoffnung, ansonsten Gleichstrom.

Gruß Uli

Hallo Uli,

ich fahre auch mit einem PWM Regler - Doppelpult von Conrad. Ich habe kein Ahnung was da jetzt genau für ein Signal rauskommt.
Aber mit besagter Lok - mittlerweile auf Maxon umgebaut - und technische baugleicher 151 mit original Motor habe ich keinerlei Probleme. Kondensator und Spulen sind noch vorhanden.

Vielleicht liegt der Fehler in der Lok, Hast du schon gereinigt, auch den Motor?

Gruß Detlef

Hallo Uli,

die analogen Loks mit Drosseln und Kondensatoren mögen die hohen Freqenzen nicht wirklich, da diese Bauteile nicht für PWM Frequenzen im Kilohertzbereich ausgelegt sind. So um die 100 Hz wäre da besser geeignet. Läuft bei mir seit über 30 Jahren ohne Probleme. Auch die Fleischmann 7375 E103 aus den frühen 80ern.

Wichtig ist jedoch bei den niedrigen Frequenzen, dass die PWM in den Pulspausen aus ist (Freilauf bzw. Offen) und nicht umgepolt oder aktiv kurzgeschlossen wird.

Beste Grüße

Tom

Ich denke auch, daß eine bessere Regelbarkeit vor allem im Bereich von 70 bis 100 Hz zu erwarten wäre. Bei 14kHz erwarte ich eigentlich eher DC Verhalten bei "nur ein" PWM. Was sonst noch alles gerade bei alten Motoren passiert, müßte man sich am konkreten Objekt mal mit dem Scope anschauen und die Stromantwort mal ansehen. Da wird man wohl je nach Motorbauart einige Unterschiede finden und vielleicht auch, daß man das besser lassen sollte. Aber wie auch immer, wir wissen noch nicht, welche Art PWM Du fährst und auch die Maschine haben wir hier nicht auf dem Tisch... also, viel Glaskugel

Hoffe trotzdem geholfen zu haben...


Gruß
Klaus


Hallo Detlef,

am Reinigen liegt es nicht. Ich hatte die Lok komplett zerlegt und nach allen Regeln der Kunst gereinigt, Motor auch im SR24-Ultraschallbad etc. wie in div. Youtube Videos gezeigt.
Nach dem Zusammenbau lief sie auf dem Gleichstrom-Testgleis einwandfrei ruhig und sauber bei allen Geschwindigkeiten. Es ist die Macke in der PWM!

Gruß Uli

Hallo Tom,

Danke für den Hinweis! Genau das Gefühl habe ich auch, insbesondere, da die Loks doch sehr unterschiedlich sind. Dass die Schlepptenderloks gut laufen, ist wohl eher glücklicher Zufall.

Ich habe nach den 5-6 Jahren Moba-Pause die alten PWM-Unterlagen ausgegraben und mich erinnert:
Es war ein Bausatz von ELV, den ich modifiziert hatte, er arbeitet aber mit 20kHz. Da kann ich nicht auf 100 Hz umstellen und muss wohl neu bauen. Auch klappt das mit dem aktiv AUS nicht. Hast Du bei 100Hz keine Brummgeräusche?

Gruß Uli

Halle Klaus,

Ja, mit DIESER PWM von ELV sollte man es wirklich besser lassen.
Die wurde bereits im Internet kommentiert und als ungeeignet befunden, wie ich jetzt erst herausgefunden habe.
Es gibt aber noch andere DC-Fahrregler ( nicht auf PWM-Basis), welche nicht nur als Drezahlsteller sondern auch Lastregler arbeiten.
Damit könnte man doch zumindest auf Steigungs- und Gefällstrecken lastunabhängig wenigstens etwas ausregeln. Das Anfahr- und Bremsverhalten dann wohl nicht.

Gruß Uli

Hallo Tom

Zitat - Antwort-Nr.: 10 | Name: Tom

die analogen Loks mit Drosseln und Kondensatoren mögen die hohen Freqenzen nicht wirklich, da diese Bauteile nicht für PWM Frequenzen im Kilohertzbereich ausgelegt sind.

Woraus ziehst du diese Erkenntnis?

Rein elektrotechnisch ist sie nicht haltbar. Bei 30 kHz ist der Ersatzwiderstand ca.:
- 20 nF = 250 Ohm
- 5 µH = 1 Ohm

Das hat kaum bis gar keine Auswirkung auf die Motorfunktion.

Dietrich

Hallo Dietrich,

die Erkenntnis ziehe ich aus 35 Jahren PWM Modellbahning in Spur N, Elektrotechnikstudium und 20 Jahre Arbeit als Schaltungentwickler im Bereich Analog/Digitalelektronik. Ich habe mich hier bewusst schwammig ausgedrückt, weil das Thema eigentlich sehr komplex ist.

Die Selbsterfahrung in endlosen Bastelstunden zur Optimierung meiner PWM Steuerungen hat mir gezeigt, das oberhalb von 500Hz die meisten analogen Loks an Kraft verlieren und nur noch widerwillig anfahren. Zudem werden sie wärmer und haben höheren Verschleiß an den Kohlen. Klar kommt das dabei auf den Typ der PWM und ihrer Regelung an. Auch das ist schwer, hier zu verallgemeinern.

Die klassische Zweipunktregelung funktioniert bei den kleinen Motoren nur mit sehr hohen Frequenzen wegen der geringen Motorinduktivitäten. Das machen ja die Digitaldekoder mit über 20 kHz und kurzen Leitungen und möglichst nichts zwischen Motor und Endstufe des Dekoders.

Analoge Loks sind historisch für die Versorgung aus Vollwellengleichrichtung über Regeltransformatoren ausgelegt. Das ist 50 Hz gleichgerichtet, also im Prinzip 100 Hz, wenn man in erster Näherung die Oberwellenanteile der Gleichrichtung vernachlässigt. Drossel und Kapaziät sollen das Störsignal der Kommutierung reduzieren und das Bürstenfeuer verringern. Historische Lösung, um den Fernsehempfang und Radio nicht zu stören.

Die Spulen in Serie zum Motor als Ohm/induktive Last mit parallelem Kondensator ergeben einen Tiefpass höherer Ordnung (mindestens 2. Ordnung) und die Gegen EMK des Motors beeinflusst das ganze noch In Abhängigkeit der Drehzahl.

Ich möchte hier gerne qualitativ bleiben und folgenden Begriff verwenden: Die analogen Loks mögen keine PWM im Bereich von einigen 100 Hz bis ca. 20 kHz. Oberhalb von 20kHz kann PWM wieder funktionieren, wenn die Beschaltung in der Lok entsprechend dimensioniert ist, und die PWM-Endstufe den Lagen Weg über Kabel und Gleis den Motor niederohmig ansteuern kann.

Kann sein, dass einige von Euch andere Erfahrungen gemacht haben, ich gebe hier nur meinen Stand wieder. Vorwiegend Arnold, Fleischmann und Minitrix Loks aus den 80ern und 90ern. Motorschäden hatte ich so gut wie keine (weniger als 5% der Loks in 30 Jahren)

Daher bleibe ich mit meinen PWMs im Mittel unter 200 Hz, meist um 90 Hz. In der On-Phase liegen ca. 12V am Gleis, in der Off-Phase keine Spannung. Freilauf über Freilaufdioden. Für die PWM habe ich früher BD675 NPN Transistoren in Emitterschaltung benutz mit Freilaufdiode gegen positive Versorgungsspannung. Heute nutze ich Vollbrücken z.B L293D, L298 und LMD 13200. Die PWM liegt jeweils am Enable Input. Durch die Nutzung der Brücken kann ich auch alternativ DIgital-DCC fahren.

Uli aus meiner Erfahrung möchte ich Dir raten mit 100 Hz PWM zu fahren mit 12 V Betriebsspannung. Das sollte analoges Rollmaterial mit 3 und 5 poligen Motoren abkönnen.

Vorsicht: Es gibt aber eine Ausnahme: Glockenankermotoren darfst Du dann nicht verwenden.

Beste Grüße

Tom

Hallo,

der Witz ist dass digitale Loks oft die gleichen Tiefpass Schaltungen drin haben, oft krass mit Ko's gegen Schienen, so dass a) die Gegen EMK stark gedämpft und b) mit Digitalsignal moduliert wird. Die Regelung ist dann sehr komplex :)

Messtechnischer Effekt sowie effektiver praktischer Effekt der "Rundfunkentstörung": Null.

Typische alte PWM Geräte und auch die ganz alten DCC Decoder verwendeten eine PWM fq im Bereich 70...150 Hz.

Vergiss die BD, viel zu langsam. Die L293/298 sind mittlerweile auch sehr in die Jahre gekommen. Sie sind zwar gutmütig, neigen nicht zum "Durchzünden", haben aber einen relativ hohen Innenwiderstand, somit Spannungsabfall und Verlüstwärme. DCC kann man damit generien, aber wenn Du mal 1-2 Amp. Strom ziehen willst wird es eng. Wehe, das Exposed Pad ist beim Pillichsdorfer Glump wieder mal nicht ordentlich verlötet!

Ich verstehe nicht, warum alle Anbieter immer nur das Arduino Motor Shield mit dem alten L298 nachbauen und keiner kommt mal mit einer ordentlichen MOSFET Brücke. Nein nicht mit den ollen mit 4 NMOS wo Dir die Charge Punp um die Ohren fliegt wenn der Motor Spikes rückspeist...

Grüße, Peter W.

Hallo Uli,

Das Brummen bei 100Hz finde ich nicht als unangenehm störend und/oder laut. Ab 200 Hz finde ich es nervig.
Tipp: Modulierte die PWM-Freqenz kontinuierlich von 70 bis 150 Hz, dann nimmst Du das gar nicht mehr wahr.

Beste Grüße & gute Nacht

Tom

Nach meiner Erfahrung ist ein PWM Offset auf einer Gleichspannung das "Beste". Volle 12 V PWM finde ich bei einigen Modellen zu brutal, einige alte Arnold-Modelle werden schnell sehr warm. Daher mische ich das Integral der PWM zu einer DC Basisspannung und lasse den PWM oben drauf. Der PWM macht dann rund 6 Volt über dem DC Signal. Das hat sich prima bewährt! Beim Anfahren sind somit die "An-Zeiten" doppelt so lang als bei 12V, liefern aber die selbe Leistung. Bei mehr als 6 Volt Effektiv-Wert steigt dann die DC Basisspannung und der PWM bleibt wie gehabt oben drauf bis dann die PWM-An-Zeiten an die Dauerspannung heranreichen. Frequenz ~75Hz. Weniger rappelt mehr, höhere Frequenz hat weniger "Kraft" beim Langsamfahren. Da ich "Dekoder am Gleis" fahre, sind alle Spannungserzeuger synchron und daher nur mit einer Frequenz unterwegs ( Startpunkt der PWM wird über Bus synchronisiert, weil sonst gibts beim Überfahren von Trennstellen Kurzschlüsse )

Hardware: Endstufe mit symmetrischer Versorgungsspannung ( <= +/- 18V ). Spannung am Gleis nach Belegtmelder ca. +/- 14V. Der Rest ist Modellbahnraumheizung . Endstufen können je Seite "abgeschaltet" werden, damit kann man PWM mit "Ein" und auch "Ein+ aktiv 0" fahren. Auch DCC geht, dann sind auch beide Endstufenseiten an.

Zitat


keiner kommt mal mit einer ordentlichen MOSFET Brücke.



Damit kann ich kein DC fahren. Von daher schöne alte "Heizungsendstufe" mit ganz normalen Bipos. Leider auch mit fettem Kühlkörper... aber irgendwie muß der Dachboden ja warm werden

Nur so... ohne E-Technik Studium

Gruß
Klaus



N’Abend Peter,

Du hast mit allem was Du schreibst Recht!
Es gibt tolle Schaltkreise die vieles mittlerweile besser im Sinne von weniger Verluste und steilere Flanken können.
Ich habe vor 25 Jahren auf die (damals potentiellen) Klassiker gesetzt...
Das ich heute für maximal 3,50 Euro inclusive. Versand fertige Baugruppen in China ordern kann, hatte ich damals nicht auf dem Schirm, aber die Teile sind jetzt die absoluten Klassiker. ( da habe ich wohl die richtige Wahl getroffen)

Booster mit viel Ampere sind nicht mein Fokus. Ich mache das lieber einer kleinen Endstufe je Block.

Jetzt kommen wir doch zu sehr vom Topic GFN 7375 ab... Sorry Uli.

Grüße

Tom

Hallo Klaus,

Deinen Ansatz finde ich immer wieder gut.
Ist aber nicht DCC kompatibel. (Hatten wir ja schon mal ausdiskutiert...

Grüße

Tom

Hallo,

auch von mir ein großes SORRY für das Abschweifen vom Thema, falls sich jemand genervt fühlt.

Ja, bei DC Offset braucht man einen Analogverstärker, Man könnte diesen als Class D Verstärker bauen, und die Induktivität des Motors als Drossel nehmen so wie die Induktivität eines Lautsprechers. Dann sind wir genau bei der >20 kHz PWM angelangt - mit einer überlagerten PWM. Nix anderes machen die Lokdecoder...

Grüße, Peter W.



Hallo Peter,

Wie wärs mit einem VNH2SP30 von ST? Der versorgt meinen Testkreis.

Tom

Zitat

Ist aber nicht DCC kompatibel.



Warum? Ich kann den DC Teil abstellen und reines Rechteck rausschieben und vom Controller entsprechend modulieren, fertig ist DCC. Hab ich was übersehen?

Gruß
Klaus


Zitat - Antwort-Nr.: 23 | Name:


Wie wärs mit einem VNH2SP30 von ST? Der versorgt meinen Testkreis.



Zitat - Antwort-Nr.: | Name: Pololu


The VNH2SP30 motor driver used by this board has been discontinued by ST.



So nee.

Grüße,
Harald.

Hallo Tom

Danke für deine ausführliche Schilderung in #16. Ähnliche Erfahrungen habe ich (Dipl.Ing. Elektrotechnik, 40 Jahre Entwicklungstätigkeit) in mehr als 45 Jahren N-Bahnerei auch gemacht.
- PWM mit ca. 80 - 90 Hz hat meine G&R-Steuerung jahrelang auf alle Motoren losgelassen. Auch viele Faulhaber-GAMs wurden jahrelang so "gequält" und entgegen gängigem Glauben haben alle überlebt. Entstörmittel konnten immer in den Fahrzeugen verbleiben.
- Seit dem Umstieg auf digital vor einigen Jahren hat die PWM jetzt meist > 20 kHz. Da müssen nur zu große Parallel-Kondensatoren zu den Motoren raus (Hobbytrain), und natürlich auch die Cs zwischen Motor und Schiene, wie schon oben von Peter erwähnt.
- PWM im Bereich 100 Hz - 10 kHz habe ich nie probiert, aber auch hier ist der Effekt der Außenschaltung unwesentlich, das Verhalten wird praktisch nur vom Motor selber bestimmt.

Dietrich

#24 Klaus,

Sorry, das wusste ich nicht. Dann passt das natürlich ohne DC Anteil.

Grüße

Tom


#25 Harald,

wusste ich nicht, dass der abgekündigt ist. Dann natürlich besser nicht.

Beste Grüße

Tom


Nur registrierte und eingeloggte User können Antworten schreiben.
Einloggen ->

Noch nicht registriert? Hier können Sie Ihren kostenlosen Account anlegen: Neuer N-Liste Account




Seiten:  123456789  ...14




Zum Seitenanfang

© by 1zu160.info;