Exklusiv bei Conrad
Dm-Toys

Link/Rank-Liste:
Stimme für 1zu160 bei Spurweite-N.de


powered by
World4You.com


1zu160 - Forum  |  Sie sind: Gast  |  Login  |  Neu Registrieren


Anzeige:
VGB: Vorbildliche N-Anlagen

Thema: Rocrail Server startet nicht automatisch
jvs1402 - 17.10.20 19:48

Hallo zusammen,

ich habe mir heute einmal die 64 Bit-Version von Rocrail installiert. Bei dieser Version startet der Rocrail-Server nicht, wie bisher, automatisch. Ich muss ihn jedes Mail vorher manuell starten.

Hat jemand Erfahrungen mit dieser Version gemacht und weiß jemand, ob man den Server auch irgendwie automatisch starten kann?

Gruß
Jürgen


Wundert mich jetzt, denn normalerweise wenn ich die Bedienoberfläche eines angelegten Projekts in der 64 bit Version öffnete, startete der Server automatisch mit. Und das Systemplattform unabhängig. Hat sich da was geändert? Im Moment liegt die PC Steuerung auf Eis bei mir.


Moin Jürgen,

woran erkenne ich eine "64-Bit-version" ?

Ich habe mal ein Bild von der "Info" angefügt.

Gruß aus Nordertown

Die von Exitus zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login


Ja, komisch. Mit der alten Version startet der Server auch automatisch. Habe gerade gelesen, dass man einen Arbeitsbereich öffnen muss, dann sollte der Server starten.

Hallo Jürgen
Der Server Startet nachdem Du den Arbeitsbereich geöffnet hast.
Wenn Du allerdings nur einen Arbeitsbereich hast und diesen immer mit Starten möchtest, dann musst Du nur in Rocview Eigenschaften -> Pfad den Planordner angeben und den Hacken bei "Lade Arbeitsbereich beim Programmstart" setzen.
Dann läuft das wie immer.
Gruß Jörg

Moin,

möchte nochmal auf meine Frage #2 hinweisen...

Gruß aus Nordertown

Hallo Exitus
Steht in deinem Bild unter der IP Adresse
win64

Bei 32Bit -> win32

Gruß Jörg

Danke Jörg,

ich hatte es zwar vermutet, da ich das Programm überhaupt erst seit August kenne, aber ich war mir eben nicht sicher.

Die Angabe "win64" hatte ich als ausgelesene Anzeige der Plattform interpretiert, auf dem das Programm läuft. Und da ich eine 64-Bit-Umgebung habe, wäre das - so wie ich es ausgelegt habe - eben nur die Bestätigung dessen.

Da ich nur mit der Arbeitsfläche "Bahnhof" (wie auf dem Bild erkenbar) arbeite, wird die natürlich auch gleich bei Programmstart geladen.. und damit auch der Server.

Gruß aus Nordertown

Vielen Dank für die Rückmeldungen, werde ich heute mal ausprobieren. Das mit dem Arbeitsbereich las ich auch schon im Wiki. Momentan starte ich den Server manuell. So wie ich las, müsste ich den Server auch auf meinem Raspberry laufen lassen können.

Hallo Exitus, an der ZIP-Datei zum Downloaden hängt der Zusatz -WIN64.

Gruß
Jürgen

Hallo Jürgen
Ja auf Raspberry Pi3 sowie der Pi4 2GB läuft ohne Probleme.
Gruß Jörg

So, jetzt läuft alles. Danke für die Tipps!


Zitat - Antwort-Nr.: 8 | Name: jvs1402

So wie ich las, müsste ich den Server auch auf meinem Raspberry laufen lassen können.



Hallo Jürgen!

Das funktioniert super! Haben gerade 2 User erfolgreich umgesetzt. Tipps und Tricks dazu gibt es im Forum von rocrail unter https://forum.rocrail.net/viewtopic.php?f=45&t=21331 . Ich habe meine Raspi Pi 4B sogar komplett ohne Maus, Tastatur und Monitor installiert. Wie das geht, kann man u.a. hier https://techgeeks.de/raspberry-pi-ohne-monitor-maus-und-tastatur-betreiben/ nachlesen.

Und um alles bequem vom Windows-PC / Notebook zu steuern, braucht man eigentlich nur zwei Tools, die es auch in portablen Versionen gibt, Putty und WinSCP. Putty dient zur Eingabe von Befehlen als säße man vor einem Terminal am Raspi und WinSCP dient zur Übertragung von Dateien zwischen PC / Notebook und Raspi. Eine wirklich tolle Sache.

Beste Grüße

Boris


Nur registrierte und eingeloggte User können Antworten schreiben.
Einloggen ->

Noch nicht registriert? Hier können Sie Ihren kostenlosen Account anlegen: Neuer N-Liste Account




Seiten:  123456789  ...14




Zum Seitenanfang

© by 1zu160.info;