Exklusiv bei Conrad
Dm-Toys

Link/Rank-Liste:
Stimme für 1zu160 bei Spurweite-N.de


powered by
World4You.com


1zu160 - Forum  |  Sie sind: Gast  |  Login


Anzeige:
WAWIKO



Seiten 1-5: 12345
Kategorie: 


Digital

Thema: Störung S88 Bus
kuh56 - 07.03.18 14:05

Bei meiner Anlage habe ich die Steuerung in einer Schublade verbaut.
Die Anlage kann wahlweise Analog als auch Digital betrieben werden.
Die Analge wurde im Winter 2016/17 als Analoganlage erstellt.
In diesem Winter war die Digitalbetrieb Ergänzung angesagt (aufwändiger als gedacht....)
Nun zum Problem.
Gestern habe ich die Anlage im Digitalbetrieb in Betrieb genommen. Dabei stellte ich fest, dass im Schubladenbereich die Rückmelder "spinnen". Das heist beim Ueberfahren eines Melders werden mehrer Nachbarmelder ausgelöst. Ich vermute, dass das am unmittelbar darunterliegenden Trafo liegt.
Gibt es eine möglichkeit den Trafo abzuschirmen?
Ansonsten muss ich ihn ausserhalb der Schublade mointieren, was eigentlich nicht meinem Konzeptt entspricht.

Gruss

huk

PS die Rückmelder sind auf dem Foto mit Tape neben den Gleisen markiert.



Die von kuh56 zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login



Hallo huk,

deine Vermutung dürfte zutreffen. Der S88 ist sehr empfindlich, was Störsignale angeht.
Und ein Wechselstromtrafo hat ein nicht gerade kleines Magnetfeld, das da reinspielt.

Es gibt entsprechende Abschirmfolien o.ä., einfach mal googeln.
Wie wirksam die sind, ist natürlich die Frage.
Eventuell kannst du auch den Trafo umsetzen, so daß er nicht mehr in der Nähe der Melder liegt?

Gruß
ChristiaN

Hallo huk,

Nochmal um die Randbedingungen eindeutig zu klären: unter den Tapes sind die Gleisfreimelder (Gleisbesetztmelder), die an die senkrecht im zweiten Bild verlaufenden Rückmelder angeschlossen sind. Diese sind als s-88 an die weiße Komponente links angeschlossen. Die s88 ist eine relativ kurze Leitung, die doch in gutem Abstand zum Trafo läuft. Eher unwahrscheinlich, dass das Signal beeinflusst wird.

Sprich: es ist eher NICHT das s88 Signal, was beeinflusst wird. Von Gleisfreimelder zu Rückmelder läuft "nur" die Prüfspannung. Dass diese beeinflusst wird, ist mir noch nicht begegnet.
(ggf. Induktion?). Oder der Gleisbesetztmelder lässt sich stören.

Prüfe mal die Abhängigkeit vom Trafo: tritt der Fehler auch auf, wenn der Trafo ausgeschaltet ist (versorge die Anlage ggf. alternativ)?

Sicherlich lässt sich der Trafo nach oben abschirmen. Mit was für Materialien das geht, weiß ich aber nicht.

Sind es immer die gleichen Melder, die zusammen gemeldet werden? Ich hatte einen ähnlichen Fall. Bin fast verzweifelt, erst gestern Abend hatte ich gesehen, dass die Datenleitung (s88-N Netzwerkkabel mit RJ45, eigentlich gut abgeschirmt) beim Einklappen der Anlage zerdrückt wurde und offenbar Adern verbunden wurden... Das sollte ausgeschlossen werden, Schubladen bieten da ja Möglichkeiten...

Umgekehrt lassen sich die Gleisbesetztmelder vom Rückmelder trennen und am Rückmelder prüfen ob der Eingang funktioniert. Vorsicht, ich kenne dein Fabrikat nicht, bei meinen müssten dazu  Gleiskontakte kurzgeschlossen werden. Dann sehe ich, ob die s88 Verbindung einwandfrei arbeitet.

Viele Grüße,

Simon




Danke für die Ausführungen.
Ich habe heute abend nochmals Tests gemacht. Nur die Rückmelder (Reedkontakte) die über dem Tragfo sind "spuken".
So zB auch wenn ich den Trafo anstelle geben 2 Rückmelder Zeichen...
Ich denke es liegt sehr warscheinlich am Trafo und nicht am Netzteil das unmittelbar neben dem HSI88 ist.
Ich werde demnächst einen Trafo extern instalieren und schauen wie sich das ganze verhaltet.

Gruss und Dank

huk

Hi,

hab ich das richtig verstanden, du schaltest mit Reedkontakten direkt die Eingänge der Rückmeldeeinheit? Und das Ganze mit recht langen Kabeln? Ich würde dir einen Versuch empfehlen:

Hintergrund deines Problems könnte Übersprechen von einer Leitung in die andere sein. Ein minimaler Impuls reicht aus um mehrere Rückmelder zu setzen wenn einer schaltet. Weiß jetzt nicht wie dein Baustein arbeitet, meine selbstgebauten haben ein RS-Flip-Fop Typ 4044 und dann ein Schieberegister, über das die Informationen zur Zentrale geschoben werden. Wird das Flip-Flop irrtümlich gesetzt, wird es ausgelesen und erst nach erfolgter Abfrage durch die Zentrale wieder gelöscht. Die falsche Information ist dann jedoch schon in der Zentrale angekommen und hat dort für Verwirrung gesorgt.
Der Trafo kann das Phänomen soweit beeinflussen, dass er durch seine Einstreuung des Magnetfeldes überhaupt erst das Übersprechen von einer Leitung auf die andere ermöglicht. Hier werden sich mehrere Effekte addieren, die in Summe ausreichen, die sehr empfindlichen Eingänge zu setzen.

Zum Reedkontakt laufen zwei Leitungen, eine davon ist entweder Masse (minus) oder Plus. Das ist prinzipiell egal, wir reden jetzt von der Leitung, die zu allen Kontakten geht, nicht die Leitung die auf den Eingang geht. Du solltest nicht den Trafo abschirmen sondern die Leitungen einzeln denn die Signalleitung wirkt wie eine Antenne und fängt damit super Störungen ein.

Die eben erwähnte gemeinsame Leitung wird als Schirm verwendet, der die andere Leitung abschirmt. Dazu kannst du Mikrofonkabel oder ähnliches nehmen. Hauptsache ist, dass du ein Drahtgeflecht um deine Signalleitung hast. Am Drahtgeflecht wird dann die eine Seite des Kontaktes angeschlossen, die sogenannte Seele kommt auf die andere Seite.

Eine andere Möglichkeit wäre, den Eingang unempfindlicher zu machen. Dazu würde ich einen hochohmigen Widerstand (sagen wir 10kOhm) vom Eingang zur Masse legen wenn der Eingang mit Plus geschaltet wird. Wie auch immer, ein Pol ist der gemeinsame (also entweder plus oder minus) Du nimmst dann den anderen und fertig.
Versuch mach klug.

Grüße Torsten


Hallo,

Zur Abschirmung des Magnetfelds eines Trafos sollte man ein Material wählen, dass sowohl elektrisch als auch magnetisch leitfähig ist, wie z.B. magnetisierbares Stahlblech. Davon ein U um die Trafogehäuse gebogen, sollte die Magnetfelder oberhalb der Trafos ganz gut dämpfen. Je dicker das Blech, umso größer die Dämpfung (zumindest für die ersten Millimeter Blechdicke). Welche Dicke bei Dir schon hilft - keine Ahnung. Gefühlsmäßig würde ich mit 1 mm anfangen.

Wenn Du feststellst (wie bei Deinem zweiten Versuch), dass es eher Schaltvorgänge sind, die Deine Elektronik beeinflussen, dann reicht ein elektrisch gut leitfähiges Material, wie z.B. Kupferblech. Das kann man im Modellbau-Bedarf in verschiedenen Stärken kaufen und lässt sich, wenn es nicht zu dick ist, leicht bearbeiten. Ich würde da bei 0,5 mm anfangen, wenn das nicht reicht, einfach doppelt verwenden.

Zu bedenken ist, dass solche - d.h. die durch Schaltvorgänge verursachten - Störungen gerne auch über die Leitungen abgestrahlt werden. Diese sollte man dann ebenfalls abschirmen bzw. zumindest Schleifenbildung vermeiden und die Leitungen verdrillen. (Das kann man auch bei den Leitungen des gestörten Systems machen).

Was nun wirklich hilft, kann man aus der Ferne schwer vorhersagen, insbesondere weil ich das gestörte System überhaupt nicht kenne.

Viele Grüße und viel Erfolg,

Udo.

Hallo,

aber erstmal den Trafo ausschalten und Meldungen prüfen. Dann sieht man ob er es ist oder nicht. Kabelei anfassen ist ja doch ein etwas größerer Aufwand...

Viele Grüße,

Simon

Das Magnetfeld vermindert sich invers im Kubik zum Abstand. Also doppelter Abstand -> 1/8 Magnetfeld. Blech in allen Ehren aber bei Magnetfeldern hilft nix so gut wie Abstand (wenn möglich). Wenn man den traditionellen Trafo mit einem Netzteil ersetzen kann, noch besser.

Grüße,
Harald.


Nur registrierte und eingeloggte User können Antworten schreiben.
Einloggen ->

Noch nicht registriert? Hier können Sie Ihren kostenlosen Account anlegen: Neuer N-Liste Account




Seiten:  123456789  ...14




Zum Seitenanfang

© by 1zu160.info;