Exklusiv bei Conrad
Dm-Toys

Link/Rank-Liste:
Stimme für 1zu160 bei Spurweite-N.de


powered by
World4You.com


1zu160 - Forum  |  Sie sind: Gast  |  Login  |  Neu Registrieren


Anzeige:
Exklusive Modelle von MTR Mende

Thema: Probleme mit DKE
Bing - 03.01.09 16:05

Hallo im Netz,
nach dem mein Laptop zu Bill Gates ins Nirvana geganen ist, habe ich die Software auf einen PC aufgespielt. Nun habe ich folgende Fehler.
Klicke ich auf die Weichenbetätigung der Schaltdecoder, ändert sich die Position der Weiche im Gleisplan (90 Grad versetzt).
Desweiteren gehen einige Weichenbetätigungen im Gleisplan nicht.
Ich habe daraufhin diese Weichen aus dem Gleisplan gelöscht und neu eingetragen. Leider ohne Erfolg.
Wer hätte da mal einen heissen Tipp?
Mit freundlichen Grüßen
Thomas


Hallo Bing

Etwas mehr Informationen könnten weiterhelfen.
Welches Betriebssystem
Welche DKE Version

Wieviel Magnetartikel eingerichtet.
Wieviel Adressen vergeben und  diese zusammenhängend genutzt !

Ich hatte so ein ähnliches Problem mit dem Entkupplersymbol:

http://81.169.177.36/rautenhaus2/component/fire...;catid=10&id=370

Gruß Frank

P.S :  H. Campe hat mir in der Vergangenheit gut geholfen.

Hi Thomas,

der Rückmeldemoduladressraum darf nur den tatsächlich benutzten Raum umfassen und darf nicht identisch sein mit dem gesamten Magnetartikeladressraum. [Programm, Optionen, Adressen]
Ich setzte 90-95 für Gleisbesetztmelder ein (ich habe auch 5 Gleisbesetztmelder), die Adressen für Magnetartikel geht bei mir von 63-99.
Als ich hier die gleichen Bereiche eingetragen hatte, trat dieses Problem auch bei mir auf (hat mich fast "wahnsinnig" gemacht).
Für alle Fälle, unter [Programm, Optionen, Schnittstelle]: Abfrageintervall der Besetztmelder 200,
Abfrageintervall für Fehlermeldungen 15, Sendebefehlpause 01.
Good luck!
Richard




Hallo Frank und Richard,
auf dem PC ist das Betriebsystem Windows 2000 und es ist die Demo Version installiert.
Da ich "wieder von vorne" anfange habe ich noch keine Adresse vergeben!(?)
Gerade deshalb bin ich sehr verwundert.
Gruß Thomas

Hi Thomas,

ich konnte das Problem bei meiner Installation jetzt nicht mehr nachstellen, bin aber (noch) sicher, das die Änderung der Adressbereiche das Problem löste...

Probiers einfach mal...

...ich habe ewig gebraucht das Problem irgendwie wegzubekommen, zwei verschiedene Versionen installiert (Vollversion und Demo) (es trat bei allen Varianten auf), auch unter verschiedenen Betriebssystemen (98 und XP).

Jetzt verwende ich XP und die Version 1.6.1.

Gruss   Richard

Hallo Richard,
ich bin weiterhin am suchen und probieren, habe aber keine Lösung gefunden.
Auf dem alten Laptop war XP als Betriebsystem vorhanden, nun habe ich wieder W 2000 (???).
Aber ich habe mal das Störbild abgebildet, da der Rechner im Inselbetrieb läuft.

Mit freundlichen Grüßen
Thomas

Die von Bing zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login


Thomas,

prüfe doch bitte mal nach, ob du W2000 in der Version SP4 installiert hast. Wenn nicht, könnte das evt. deine Unbill erklären.
Wobei "Downgrade XP->W2000" in den seltensten Fällen problemlos abläuft.

Gruß,
Günter

Hallo Günter,
ich bedanke mich für diesen Hinweis. Ich bin aber nun an der Grenze meiner PC Kenntnisse.
Jetzt bin ich auf die Hilfe meiner Kinder angewiesen!
Da merkt man wie alt man ist
Schönen Abend noch
Thomas

Hallo Thomas,

hast Du DKE auf dem PC mit Windows 2000 neu installiert oder hast Du eventuell die DKE Software einfach vom XP Notebook kopiert. Eine Neuinstallation ist Grundvoraussetzung für die einwandfrei Funktion von DKE. DKE ist in Visual Basic Version 6 programmiert, und es könnte sein das einige DLLs nicht auf dem aktuellen Stand sind. Es könnte aber auch sein, dass Dein Windows 2000 auf dem PC "verhunzt" ist. Aber in dem Fall würde nur eine Neuinstallation von Windows 2000 helfen, wenn man keine Kenntnisse der internen Strukturen von Windows hat.
Hast Du die Hinweise in der Liesmich-Datei beachtet, speziell in Bezug auf Einstellung der Display-Eigenschaften.

Grüße von Ernie.

Edit:
Noch ein kleiner Hinweis. Die Demoversion (auch wenn bei MDVR auf der Seite Version 1.5 steht) hat, wenn man sie neu herunterlädt die Version 1.7.1. Eventuell hilft das ja.




Hallo Ernie,
ääääääääääääähhhhhhhhhhhhhh!!!
Also mein Sohn wird erst mal die SP4 auf den Rechner spielen.
Dann will ich eine neue Demo Version verwenden. Mal sehen ob der Nachwuchs das hinbekommt.
Besten Dank für die Untertützung
Mit freundlichen Grüßen
Thomas

Hallo Bing

Die Version wird gleich nach dem Start der Testversion gezeigt .
Nach dem Drücken von O.K steht
****************************************************************************
Lieber Anwender der kleinen Eisenbahn.

Diese Datei wurde erstellt, um neue Themen zu beschreiben, die
noch nicht in der Hilfedatei eingebunden sind.

update 1. X
*****************************************************************************

update 1.X
Das ist die Version die du gestartet hast .

Zum weiteren scheint in der Version die Standartadressen nicht korrekt zu sein

http://img371.imageshack.us/my.php?image=dkewindowsxpxo9.jpg

Schaut doch bitte mal ob das bei euch auch so ist.

DKE starten
dann O.K drücken
Schließen wählen

Programm wählen
Option wählen
Adressen wählen

Nach meinen Informationen konnten 5 Adressen Besetztmelder zusammenhängend und 5 Adressen Magnetartikel zusammenhängend angegeben werden.

Ansonsten schicke Dein DKE Verzeichnis

Gruß Frank

Hallo,

von hier, weiß ich die Versionsnummer.
Habe einen Hexdump gemacht. siehe Bild.

Grüße von Ernie.


Die von Ernie zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login


Hi Thomas,

das Bild mit den verdrehten Weichen sah bei mir genauso aus; Frank hat ein super Bild mit dem Einstellmenue geschickt; änder doch mal die Zahlen auf die dort angegebenen Werte.

Ich glaube nicht, das Deine Win 2000 Installation verhunzt ist...

Ernie, ich finde die Versionsnummer raus, indem ich unter Hilfe (oder hier "?") auf Info klicke...  

Gruss  Richard

Hallo Richard,

Dein Hinweis ist natürlich richtig und einfacher. Aber das geht nur, wenn ich DKE schon installiert habe. Da ich aber die neu runter geladene Version noch nicht installiert habe und ich gerne vorher wissen wollte, welche Version ich da runter geladen habe, bin ich diesen Weg gegangen. Zumal bei MDVR auf der Webseite unter dem DL-Link noch Version 1.5 steht. Die Version 1.7.1 ist zudem auch schon alt und stammt aus dem Jahr 2005. Wenn der Fehler so ist, wie Du es beschreibst, dass durch die falschen Zahlen im Einstellmenue, die Weichen um 90 Grad gedreht werden, zeugt das nicht gerade von guter Programmierung.

Grüße von Ernie.

Hi Ernie,

Die Idee mit einem Hexdump ist super, die nehme ich in mein Repertoire auf.

Ich nehme die Programmierer von DKE in Schutz: Ich glaube, da steckt so gut wie keine Mannpower dahinter und dann kann man nicht jede Kombinationsmöglichkeit durchprobieren...
Das verzwickte Verdrehen der Weichen trat bei mir mit allen DKE-Versionen auf, woraus ich schließe, daß zum einen keiner das Problem zurückgemeldet hat (es tritt wohl nur selten auf), zum anderen die Ursache sehr tief im ursprünglichen Quellcode liegt und so von Änderungen und Verbesserungen kaum oder nie berührt wird.

Das DKE-Programm ist aber insgesamt sehr einfach und gut aufgebaut, funktioniert (von diesem Problem"chen" abgesehen) einwandfrei und ist für den Funktionsumfang unschlagbar günstig.

Mich ärgert, daß ich das Problem nicht mehr nachstellen kann: Thomas, kannst Du Deine
Rückmeldemoduladressen und Magnetartikeladressen, wie sie im DKE (mit dem Problem) eingestellt sind, mitteilen?

Gruss   Richard



Hallo Leute
Es hat geklappt!!!
Ich weis zwar nicht warum
aber man muss ja nicht alles verstehen.

Besten Dank und noch einen schönen Abend
Mit freundlichen Grüßen
Thomas

Hallo Thomas,

freut mich, dass es jetzt läuft. Wäre schon interessant gewesen, zu wissen woran es gelegen hat. Mich interessiert aber unabhängig davon, ob Du jetzt die neue Version 1.7.1 verwendest.

Grüße von Ernie.

Hallo RGK aus M.

zu 12 )  Da muß ich mich schlecht ausgedrückt haben.

Diese Werte standen bei mir nach der Installation von DKE 1.7 unter Windows 2000 und XP
jeweils in dem Programm.
Ich glaube aber das die Werte nicht korrekt sind.

Es sollen nur 5 zusammenhängende Adressen vergeben werden.

Bei dem Beispiel sind es deutlich mehr (63-94).

Gruß Frank

P.S : Bei mir kann ich mit der Demoversion 1.7 keine Fahrzeugdekoder  einstellen.
Das Problem ist bekannt .

Deshalb habe ich vor einiger Zeit DKE deinstalliert und nutze das Programm von Daniel M

Hallo Frank,

woher hast die Information "nur 5 zusammenhängende Adressen". Ich habe in sämtlichen Dokumentationen und Helpdateien von DKE nichts darüber gefunden.

Es folgt ein Auszug aus der Liesmichdatei der Demoversion 1.7.1
-------------------------------------------------------------------------------------------------------------------------
Es stehen 99 Adressen zur Verfügung.
Diese können Sie für Triebfahrzeuge, Magnetartikel (Weichen, Signale) oder Besetztmelder
verwenden.
Von den 99 Adressen können nur 7 für Besetztmeldeadressen genutzt werden (Die kleine Eisenbahn).
Das sind 7 x 8 Anschlüsse = 56 Besetztmelder.
Alle übrigen Adressen stehen für Weichen, Signale und Loks zur Verfügung.
------------------------------------------------------------------------------------------------------------------------------
Auch hier ist nichts darüber zu finden. Also demnach ist da keine Begrenzung von 5 zu sehen.

Grüße von Ernie.



Hi Thomas,

es freut mich, daß DKE jetzt bei Dir läuft!

Fassen wir zusammen:
Wenn sich im Gleisplan Weichen verdrehen, kann man das Problem durch eine Veränderungen bei den Rückmeldemoduladressen lösen. Nach den DKE-Unterlagen 1.7.1 dürfen max. 7 Besetztmeldeadressen genutzt werden, wobei diese Adressen einen zusammenhängenden Bereich abdecken sollten. z.B. 1-7, 83-89, 90-96 oder so.
Das deckt sich mit meinen Einstellungen (5 Adressen <7) und meinen Erfahrungen, daß diese Änderung das Problem löst.

Ich habe bei mir die Rückmeldemoduladressen auf 80 bis 95 verstellt, und jetzt ist nach einigem Schalten das Problem auch tatsächlich aufgetaucht! (siehe Bilder)

Jetzt hoffe ich, daß ich das Problem durch ein Rückändern der Adressen wieder loswerde!
So, ausprobiert, es klappt alles wieder ohne "Weichendreher"! (wobei ich die eine verdrehte Weiche neu einzeichnen und verknüpfen musste).

Gruss   Richard

P.S.: Vielleicht sollten wir diese Erfahrung Herrn Campe melden, er könnte ja eine "Abfangschleife" programmieren, wenn die Besetztmelder mehr als 7 Adressen umfassen, bevor es die Stellwerke zerschießt.



Die von RGK aus M. zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login


Hallo Richard,

Danke für Deine Tests. Jetzt bleibt nur noch zu klären, ob die Ursache mehr als 7 Rückmeldeadressen ist oder ob die Ursache auch damit zusammen hängt, dass die Magnetartikeladressen den Bereich der Rückmeldeadressen überlappen.
Denn Du hattest für Rückmelde 80 bis 95 und für Magnetartikel 63 bis 95 und damit überlappt der eine den anderen Bereich. Es kann aber auch sein, dass man beide Fehler machen muss.
Ich werde der Sache demnächst mal genauer auf den Grund gehen.

Grüße von Ernie.

Hallo nochmal,

grundsätzlich kann ich bei SX, eine Adresse, die ich für Rückmeldung verwende, nicht auch für einen Magnetartikel verwenden. Dieses ist der Normalfall. Es gibt aber auch die Ausnahme wo die Verwendung der gleichen Adresse für Beides Sinn macht. Wenn ich mit einer Rückmeldung einen Magnetartikel schalten will. Beispiel: per Besetzmeldung eine Schranke schliessen.  Es gibt da Hunderte von Anwendungen wo das Sinn macht. Bei DKE scheint dieses aber wohl nicht vorgesehen zu sein.

Es wäre vielleicht mal sinnvoll Herrn H.-G. Campe darüber zu informieren, so dass er sich mal zu diesem Thema äussern kann. Da ich kein großer Benutzer von DKE bin, da ich selber programmiere und deshalb mich nur mit meinen eigenen Programmierfehlern zu plagen habe, wäre es wohl besser, dass würde jemand tun, der schon mal Kontakt zu Herrn Campe hatte oder immer noch hat. Der Beste dafür wäre MDVR.

Grüße von Ernie.

Edit: Bild hinzugefügt.
Herr Campe weißt in seiner Hilfeauf Adressenkonflikte bei Doppelbelegung hin.


Die von Ernie zu diesem Beitrag angefügten Bilder können nur von registrierten Usern gesehen werden - Login




Hallo,

ich habe eine Email mit Link zu diesem Thread an Herrn Campe gesendet.
Mal sehen ob es eine Antwort gibt.

Grüße von Ernie.

Edit: Habe ausserdem einen Thread bei Rautenhaus eröffnet.

http://81.169.177.36/rautenhaus2/component/fir...catid=10&id=1174



Hallo,

Herr Campe hat in dem in Nr.22 genannten Link Stellung bezogen und die Ursachen genannt.

Grüße von Ernie.

Hallo Ernie .

Die einzige Begrenzung die ich finde ist 5
Ich habe in den  Versionsbeschreibungen  von 1.7 nicht mehr gefunden.
Eventuell habe ich noch eine ältere Versionsbeschreibung  als du Sie hast

.


update 1.4 :
============
1.) Die kleine Eisenbahn ist jetzt auch für Betriebssysteme wie
    Windows XP, Windows 2000 und Windows NT geeignet.

2.) Auf Wunsch von Vereinen wurde die Anzahl der Fahrstraßen von 30
    auf 60 erhöht.

3.) Im Lok-Tacho wurde die Hornfunktion hinzugefügt.

4.) Wer will, kann nun auch eine Weichenrückmeldung hinzuschalten.
    Diese Funktion wird unter Optionen, im Register Adressen
    eingestellt.

    Bei der Abfrage der Magnetartikel verhält sich das Programm
    genauso wie bei den Besetztmeldern. Die Adressen für die
    Magnetartikel müssen zusammenhängend sein. Je schneller Ihr
    Rechner, um so mehr Adressen können für die Rückmeldungen
    eingetragen werden. Sonst gilt die Begrenzung von 5 Adressen,    !!!!!!!!!!!!!!
    gleich 40 Magnetartikel.


Gruß Frank

Und danke für die Information das es 7 sind

Hallo Frank,

jetzt habe ich es auch gefunden. In der Datei Neu17.TXT steht es auch unter Update 1.4.
Da habe ich nicht mehr so genau hingesehen. Dies bedeutet bei älteren Versionen waren es mal 5. Ich finde es gut, dass Herr Campe eine klare Aussage zur Fehlerursache gemacht hat.

Grüße von Ernie.


Nur registrierte und eingeloggte User können Antworten schreiben.
Einloggen ->

Noch nicht registriert? Hier können Sie Ihren kostenlosen Account anlegen: Neuer N-Liste Account




Seiten:  123456789  ...14




Zum Seitenanfang

© by 1zu160.info;